FB

A cross-site scripting vulnerability was discovered in the popular Elementor page builder plugin.
In a worst case scenario an attacker would be able to take over your site and do whatever he wanted with your site and data.
We urge every user of the Elementor plugin to immediately update to the latest version which is 3.1.4 at the time of writing.
We are here to help you if you have any questions about the vulnerability or if your site is affected at all.
We offer a maintenance contact that offer you peace of mind as we are updating your site as soon as the vulnerability become available.
From as little as 5 Euro a month you can stop worrying about Word Press update
Click here to check our maintenance contract.

Share This